Bir Uygulama Örneği: Şimdi küçük bir örnekle Excel’de hücrelere veri giriş işlemini pekiştirelim. Bu örnekte basit bir satış fatura hazırlanmaktadır. Buna göre faturada, ürünün adı, satış miktarı, satış fiyatı, tutar ve toplam fatura tutarı bulunmaktadır.

            Böyle bir işlemde, ilk olarak değerlerin neyi ifade ettiğini anlatacak sütun başlıklarının metin olarak ilgili hücrelere girilmesi, tablonun anlaşılır olması açısından önemlidir. Burada hücrelere alfabetik değer girişi yapılmaktadır.


(Metinler bulundukları hücreye sığmamaktadır. Sütun genişletme işlemi uygulayınız.)

            Excel gibi ve daha bir çok bilgisayar programında bazı değerlerin mutlak kullanıcı tarafından girilmesi gerekir. Bu tip değerler değişken adı verilir. Değişken olarak adlandırılan bu değerlerin girilmesi, formüllerin sonuç vermesi açısından da önemlidir. Çünkü, formüller değişkenlerin aldıkları değerlere göre işlem yaparlar. Aşağıda örneğimizin değişken yapıdaki, yani kullanıcı tarafından girilmesi gereken değerlerin girilmiş hali görülmektedir. Miktar ve fiyat sütunundaki hücrelere sayısal değer girişi yapılmıştır.

            Tablonun verileri girildikten sonra sıra, sonuçları değişken yapıdaki değerlere göre belirlenecek olan formüllerin yazılmasına geldi. Bilindiği üzere tutarın hesaplanmasında miktar ile fiyatın çarpımı formülü kullanılmaktadır. Yani formül, Tutar = Satış Miktarı*Satış Fiyatı şeklindedir. Bunun için ilgili değerlerin bulunduğu hücrelerin adresleri kullanılarak ilk ürün için =B2*C2 formülü yazılarak sonuç elde edilir.

            İşlem diğer ürünlere de uygulanmak istendiğinde, ilgili hücrelere sırasıyla =B3*C3 ve =B4*C4 yazılacaktır.

            Böylece her ürünün tutarı hesaplanmıştır. Sonuçta toplam tutarın hesaplanması için D5 hücresine =D2+D3+D4 formülü yazılır. Burada Excel’in hazır fonksiyonlarından TOPLA fonksiyonu kullanılarak da sonuca ulaşılabilir. Bunun için D5 hücresine =TOPLA(D2:D4) ifadesi yazılır. Bu işlemin sözel anlatımı, “D2 hücresinden D4 hücresine kadar olan hücrelere toplama işlemi uygula” şeklindedir.

            Ancak, faturanın üç satırdan değil de, elli satırdan oluştuğunu düşünecek olursanız, işlemin formül olsa dahi her satır için aynı formülün tekrar yazılmasının oldukça külfetli olacağını takdir edersiniz. Öyle ise ne yapılmalıdır? Bu sorunun cevabını Hücre Üzerinde Uygulamalar konusu içinde Hücreleri Doldurma başlığı altında bulabilirsiniz.

Devam